Tärkein Pc Ja Mac Ovatko sähköpostit kirjainkoon mukaisia?

Ovatko sähköpostit kirjainkoon mukaisia?



Paljon hämmennystä siitä, ovatko sähköpostiosoitteet kirjainkokoisia vai ei. Jotkut sanovat olevansa, kun taas toiset väittävät, etteivät ole. Joten, kuka on oikeassa? Tässä artikkelissa tarkastelemme, ovatko sähköpostiosoitteet kirjainkoolla vai kirjainkoon erottomia.

Ovatko sähköpostit kirjainkoon mukaisia?

Mikä tekee sähköpostiosoitteesta?

Sähköpostiosoite koostuu kolmesta osasta - paikallisesta osasta (tunnetaan myös nimellä käyttäjätunnus), @ -merkistä ja verkkotunnuksen osasta. Jokaisella osalla on oma roolinsa ja siihen sovelletaan omia sääntöjään. Tässä on lyhyt yleiskatsaus.

Standardin mukaan sähköpostiosoitteen paikallinen osa voi olla enintään 64 merkkiä pitkä ja se voi koostua rajoitetusta merkistöstä. Näitä ovat isot ja pienet latinalaiset aakkoset, numerot 0-9, piste ja erikoismerkit. Erikoismerkkejä ovat '[email protected] # $% ^ & * () _- + = [] {} ~. Se on liitetty toimialueosaan @ -merkillä.

Verkkotunnuksen osa voi olla enintään 255 merkkiä pitkä. Se voi sisältää latinalaisen aakkosen kirjaimia (sekä pieniä että isoja kirjaimia), numeroita 0-9 ja tavuviivan. Väliviiva ei voi aloittaa tai lopettaa verkkotunnuksen osaa.

Myös kansainvälisiä symboleja voidaan käyttää, tosin myöhemmin.

Onko kirjainkoko merkitsevä?

Oikea vastaus tähän kysymykseen on sekä kyllä ​​että ei. Mukaan RFC 5321 , sähköpostiosoitteen paikallinen osa erottaa kirjainkoon. Tämä tarkoittaa, että teoriassa [sähköpostin suojaus] ei ole sama kuin [sähköpostin suojaus]. Sähköpostin tarjoajilla on kuitenkin vapaus kohdella paikallisia osia sekä kirjainkoon mukaan että kirjainkoon mukaan.

Esimerkiksi [email protected], [email protected] ja [email protected] ovat teoriassa erilaisia ​​sähköpostiosoitteita. On helppo nähdä, miten tämä voi aiheuttaa ongelmia ja vähentää käyttökokemusta, jos postipalvelin päättää käsitellä paikallisia osia kirjainkoon mukaan. Siksi monet palveluntarjoajat pitävät sähköpostiosoitteen paikallista osaa erottumattomana.

kuinka etsiä elokuvia Pluto TV: stä

Mitä tulee verkkotunnuksen osaan, RFC 1035 määrätään, että se on aina kirjainkoon erottamaton. Tämä tarkoittaa, että voit kirjoittaa sen pienillä, isoilla tai molemmilla yhdistelmillä ja sähköpostiosoitteesi päätyvät samaan osoitteeseen. Käytännössä [email protected], [email protected] ja [email protected] ovat sama sähköpostiosoite.

Käytännössä

Vaikka sähköpostiosoitteet ovat vain osittain kirjainkokoisia, on yleensä turvallista ajatella niitä kirjainkoon erottumattomina. Kaikki suuret palveluntarjoajat, kuten Gmail, Yahoo Mail, Hotmail ja muut, käsittelevät sähköpostiosoitteiden paikallisia osia kirjainkoon mukaan. Tästä huolimatta sinun on tarkistettava sen sähköpostipalvelun säännöt, jolla haluat luoda sähköpostin.

Edellä mainittu RFC 5321 suosittelee, että uudet sähköpostiosoitteet luodaan vain pienillä kirjaimilla mahdollisten sekaannusten ja toimitusongelmien välttämiseksi.

Toisaalta, jos ystäväsi tai työtoverisi sähköpostiosoite sisältää isoja ja pieniä kirjaimia, on suositeltavaa kirjoittaa se sellaisena kuin se on, kun lähetät heille sähköpostia. Jos näin ei tehdä, sähköpostia ei välttämättä toimiteta. Tämä ei kuitenkaan ole ongelma suurten sähköpostipalvelujen, kuten Gmailin, Yahoo Mailin, Hotmailin ja muiden, kanssa.

Lisäksi Gmail on epäherkkä pisteille, jotka löytyvät sähköpostin paikallisesta osasta, kun kyse on käyttäjätilin tunnistamisesta. Tämä tarkoittaa, että jos [email protected] -tili on olemassa, et voi rekisteröidä [email protected] tai [email protected]

Kansainvälistyminen

Alun perin sähköpostiosoitteita voitiin rekisteröidä vain käyttämällä latinalaisia ​​aakkosia, numeroita ja rajoitettua joukkoa erityisiä ASCII-merkkejä. Kuitenkin IETF (Internet Engineering Task Force) on myöhemmin kehittänyt säännöt ja standardit kansainvälisten merkkien sisällyttämiseksi.

RFC6530 oli ensimmäinen, joka sisälsi ja sääteli kansainvälisten merkkien käyttöä. RFC6531 laajennettu sääntöihin ja standardeihin. Tämän jälkeen säännöt ja standardit päivitettiin RFC6532 ja RFC6533 .

Voit nyt rekisteröidä sähköpostiosoitteen useilla aakkosilla, merkeillä ja komentosarjoilla. Joitakin yleisimmin käytettyjä ovat latinankieliset merkit diakriitikoilla, kreikkalaiset aakkoset, perinteiset kiinalaiset merkit, japanilaiset merkit (hiragana, katakana ja kanji), kyrilliset aakkoset, useat intialaiset komentosarjat sekä useita muita.

Kansainvälisten sähköpostiosoitteiden sisällyttäminen ja yhteensopivuus vaihtelee palveluntarjoajan mukaan. Jopa jotkut suurimmista palveluntarjoajista eivät ole täysin yhteensopivia kansainvälisten osoitteiden kanssa. Esimerkiksi Google sallii sinun lähettää sähköpostia kansainväliseen osoitteeseen, mutta se ei salli sinun luoda sitä. Outlook 2016: lla on samanlainen toiminto.

Johtopäätös

Toisin kuin verkkotunnusosassa, sähköpostiosoitteen paikallinen osa erottaa isot ja pienet kirjaimet. Tästä huolimatta monet sähköpostipalvelujen tarjoajat päättävät jättää paikallisen osan kirjainkoon huomioon käytännön syistä ja kannustavat ihmisiä luomaan sähköposteja vain pienillä kirjaimilla.

Mielenkiintoisia Artikkeleita

Toimituksen Valinta

Kuinka ottaa tumma tila käyttöön Notionissa
Kuinka ottaa tumma tila käyttöön Notionissa
Jos käytät Notion muistiinpanosovellusta, saatat haluta aktivoida Tumman tilan asetuksen. On monia syitä, miksi ihmiset suosivat tummaa tilaa, joko tietokoneen lähettämän valon vähentäminen, silmien rasituksen torjuminen,
Kuinka antaa järjestelmänvalvojalle pääsy toiselle käyttäjälle ristiriidassa
Kuinka antaa järjestelmänvalvojalle pääsy toiselle käyttäjälle ristiriidassa
https://www.youtube.com/watch?v=zV6ZGRXUvuE Olet asettanut itsellesi suloisen palvelimen Discordiin. Muutama lähimmistä silmuistasi, joitain uusia melko mahtavia ihmisiä, ja paikka kukoistaa. Haluat ajatella, että sinä
5 parasta Android-emulaattoria Macille vuonna 2024
5 parasta Android-emulaattoria Macille vuonna 2024
Saatavilla on paljon upeita Android-sovelluksia, mutta et voi käyttää niitä Mac-tietokoneellasi ilman emulaattoria. Pyrimme tuomaan sinulle tämän luettelon parhaista Android-emulaattoreista Macille.
Kuinka sammuttaa iPhone käyttämättä virtapainiketta
Kuinka sammuttaa iPhone käyttämättä virtapainiketta
https://www.youtube.com/watch?v=jPy4i0dbh-U Älypuhelimista tulee monimutkaisempia vuosittain, ja olet ehkä huomannut kehittyvän trendin. Nykypäivän puhelimissa on aina ainakin kaksi tapaa tehdä sama asia, yleensä
Suoritus ja viimeistely Apex Legendsissä
Suoritus ja viimeistely Apex Legendsissä
Apex Legendsin kaltaisen PvP-pelin päättäjät tarjoavat mahdollisuuden hieroa pelaajan kasvoja tappiossaan ja päättää pelielämänsä viimeisellä kukoistamisella. Ne ovat keskeinen osa monia tietokonepelejä ja
Sanyo Xacti VPC-HD700 -katsaus
Sanyo Xacti VPC-HD700 -katsaus
Erottuvat pistoolikahvan Xacti-videokamerat ovat olleet noin vuodesta 2003, jolloin tarkastelimme Sanyo VPC-C1: tä. Alkuperäisen mallin videonlaatu ei ollut tarpeeksi hyvä perustelemaan sen korkeaa hintaa, mutta asiat ovat sittemmin muuttuneet
Parhaat käsityömallit [tammikuu 2020]
Parhaat käsityömallit [tammikuu 2020]
Käsite on uusi tuottavuussovellus, jonka avulla voit järjestää työviikon. Runsailla työkaluilla ja malleilla pystyt rakentamaan työsi mieleisekseen. Toisin kuin muut sovellukset, kuten OneNote, Notion estää infrastruktuurin